U5303A User Manual

You are here: U5303A User Manual

Agilent Technologies

U5303A PCIe High-speed Digitizer

2/1 Channel, 12-bit, 1.6/3.2 GS/s, with on-board signal processing

User Manual

Introduction

This help document is intended to provide in-depth information and reference material specific to your digitizer product.

For information on getting started with your digitizer, please refer to the StartUp Guide which was delivered with your product or may be downloaded from the Agilent Technologies website.

Contents:

Notices & General Information

Introduction

Front Panel Features

Channel Input

Data Acquisition

Trigger

External Clock & Reference

Calibration

Trigger Output

Multi-Purpose Inputs and Outputs

Signal Processing Options

Electrical, Environmental & Physical Specifications

Programming Information

Utilities

Accessories

© Agilent Technologies, Inc. 2014. | Help version: Tuesday, August 19, 2014
Part No: U5303-90005 |


Notices

© Agilent Technologies, Inc. 2014

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

U5303-90005

Support

To contact Agilent for sales and technical support, refer to the “support” links on the following Agilent web resources:

www.agilent.com/find/Digitizers - Home page for the entire range of Agilent modular digitizer products.

www.agilent.com/find/assist - Worldwide contact information for repair and service.

www.agilent.com/find/tips - Information on preventing damage to your Agilent equipment.

Regulatory Compliance

This product has been designed and tested in accordance with accepted industry standards, and has been supplied in a safe condition. To review the Declaration of Conformity, go to http:/regulations.corporate.agilent.com/DoC/search.htm.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information

contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Conventions Used in this Document

The following convetions are used in this document:

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

A Caution notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met

This is a note, drawing the reader's attention to important information, caveats, etc.

'Italic' text denotes a reference to a quoted name or entity. e.g."Press the 'Run' button."

Bold Italic text is used to emphasize an important action point in the text. e.g. "Open the View menu and select the All option."

mono text is used for sections of code, programming examples and operating system commands. e.g. "Type the command >> Run -all"

Underlined Italic text denotes paths or file names. e.g. "The file is located in the folder, e.g...\Agilent\MD1\.."

Safety Notices

The following safety precautions should be observed before using this product and any associated instrumentation.

This product is intended for use by qualified personnel who recognize shock hazards and are familiar with the safety precautions required to avoid possible injury. Read and follow all installation, operation, and maintenance information carefully before using the product.

If this product is not used as specified, the protection provided by the equipment could be impaired. This product must be used in a normal condition (in which all means for protection are intact) only.

The types of product users are:

  • Responsible body is the individual or group responsible for the use and maintenance of equipment, for ensuring that the equipment is operated within its specifications and operating limits, and for ensuring operators are adequately trained.
  • Operators use the product for its intended function. They must be trained in electrical safety procedures and proper use of the instrument. They must be protected from electric shock and contact with hazardous live circuits.
  • Maintenance personnel perform routine procedures on the product to keep it operating properly (for example, setting the line voltage or replacing consumable materials). Maintenance procedures are described in the user documentation. The procedures explicitly state if the operator may perform them. Otherwise, they should be performed only by service personnel.
  • Service personnel are trained to work on live circuits, perform safe installations, and repair products. Only properly trained service personnel may perform installation and service procedures.

Agilent products are designed for use with electrical signals that are rated Measurement Category I and Measurement Category II, as described in the International Electrotechnical Commission (IEC) Standard IEC 60664. Most measurement, control, and data I/O signals are Measurement Category I and must not be directly connected to mains voltage or to voltage sources with high transient over-voltages. Measurement Category II connections require protection for high transient over-voltages often associated with local AC mains connections. Assume all measurement, control, and data I/O connections are for connection to Category I sources unless otherwise marked or described in the user documentation.

Exercise extreme caution when a shock hazard is present. Lethal voltage may be present on cable connector jacks or test fixtures. The American National Standards Institute (ANSI) states that a shock hazard exists when voltage levels greater than 30 VRMS, 42.4 V peak, or 60 VDC are present. A good safety practice is to expect that hazardous voltage is present in any unknown circuit before measuring.

Operators of this product must be protected from electric shock at all times. The responsible body must ensure that operators are prevented access and/or insulated from every connection point. In some cases, connections must be exposed to potential human contact. Product operators in these circumstances must be trained to protect themselves from the risk of electric shock. If the circuit is capable of operating at or above 1000 V, no conductive part of the circuit may be exposed.

Do not connect switching cards directly to unlimited power circuits. They are intended to be used with impedance-limited sources. NEVER connect switching cards directly to AC mains. When connecting sources to switching cards, install protective devices to limit fault current and voltage to the card.

Before operating an instrument, ensure that the line cord is connected to a properly-grounded power receptacle. Inspect the connecting cables, test leads, and jumpers for possible wear, cracks, or breaks before each use.

When installing equipment where access to the main power cord is restricted, such as rack mounting, a separate main input power disconnect device must be provided in close proximity to the equipment and within easy reach of the operator.

For maximum safety, do not touch the product, test cables, or any other instruments while power is applied to the circuit under test. ALWAYS remove power from the entire test system and discharge any capacitors before: connecting or disconnecting cables or jumpers, installing or removing switching cards, or making internal changes, such as installing or removing jumpers.

Do not touch any object that could provide a current path to the common side of the circuit under test or power line (earth) ground. Always make measurements with dry hands while standing on a dry, insulated surface capable of withstanding the voltage being measured.

The instrument and accessories must be used in accordance with its specifications and operating instructions, or the safety of the equipment may be impaired.

Do not exceed the maximum signal levels of the instruments and accessories, as defined in the specifications and operating information, and as shown on the instrument or test fixture panels, or switching card.

When fuses are used in a product, replace with the same type and rating for continued protection against fire hazard.

Chassis connections must only be used as shield connections for measuring circuits, NOT as safety earth ground connections.

If you are using a test fixture, keep the lid closed while power is applied to the device under test. Safe operation requires the use of a lid interlock.

Instrumentation and accessories shall not be connected to humans.

Before performing any maintenance, disconnect the line cord and all test cables.

To maintain protection from electric shock and fire, replacement components in mains circuits – including the power transformer, test leads, and input jacks – must be purchased from Agilent. Standard fuses with applicable national safety approvals may be used if the rating and type are the same. Other components that are not safety-related may be purchased from other suppliers as long as they are equivalent to the original component (note that selected parts should be purchased only through Agilent to maintain accuracy and functionality of the product). If you are unsure about the applicability of a replacement component, call an Agilent office for information.

No operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electrical shock do not remove covers. For continued protection against fire hazard, replace fuse with same type and rating.

Front and Rear Panel Symbols:

The CE mark is a registered trademark of the European Community.

The C-Tick mark is a registered trademark of the Australian Spectrum Management Agency.

This symbol indicates product compliance with the Canadian Interference-Causing Equipment Standard (ICES-001). It also identifies the product is an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).

South Korean Class A EMC Declaration. this equipment is Class A suitable for professional use and is for use in electromagnetic environments outside of the home.

A 급 기기 ( 업무용 방송통신기자재 ) 이 기기는 업무용 (A 급 ) 전자파적합기기로서 판 매자 또는 사용자는 이 점을 주 의하시기 바라 며 , 가정외의 지역에서 사용하는 것을 목적으 로 합니다 .

This symbol indicates separate collection for electrical and electronic equipment, mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive, 2002/96/EC).

This symbol on an instrument means caution, risk of danger. You should refer to the operating instructions located in the user documentation in all cases where the symbol is marked on the instrument.

This symbol indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product.

ESD Sensitive Device

This symbol indicates the instrument is sensitive to electrostatic discharge (ESD). ESD can damage the highly sensitive components in your instrument. ESD damage is most likely to occur as the module is being installed or when cables are connected or disconnected. Protect the circuits from ESD damage by wearing a grounding strap that provides a high resistance path to ground. Alternatively, ground yourself to discharge any built-up static charge by touching the outer shell of any grounded instrument chassis before touching the port connectors.

This symbol denotes a hot surface. The side cover of the module will be hot after use and should be allowed to cool for several minutes.

Cleaning Precautions:

To prevent electrical shock, disconnect the Agilent Technologies instrument from mains before cleaning. Use a dry cloth or one slightly dampened with water to clean the external case parts. Do not attempt to clean internally. To clean the connectors, use alcohol in a well-ventilated area. Allow all residual alcohol moisture to evaporate, and the fumes to dissipate prior to energizing the instrument.

Definitions for specifications

Specifications describe the warranted performance of calibrated instruments that have been stored for a minimum of 2 hours within the operating temperature range of 0 to 45 °C, unless otherwise stated, and after a 45 minute warm-up period. Data represented in this document are not specifications unless otherwise noted.

Characteristics describe product performance that is useful in the application of the product, but that is not covered by the product warranty. Characteristics are often referred to as Typical or Nominal values.

  • Typical describes characteristic performance, which 80% of instruments will meet when operated over a 20 to 30 °C temperature range. Typical performance is not warranted.
  • Nominal describes representative performance that is useful in the application of the product when operated over a 20 to 30 °C temperature range. Nominal performance is not warranted.


TIP: Help Search Techniques

You are here: U5303A User Manual > Notices & General Information > TIP: Help Search Techniques

TIP: Help Search Tricks

In the help system, a basic search of topics consists of the word or phrase that you want to find. You can, however, improve your search results by using wildcard expressions, nested expressions, Boolean operators, and searching similar word matches, previous results, and topic titles only.

Performing a Basic Full-Text Search

  1. In the navigation pane, click the Search tab and then type the word or phrase that you want to find. Use the right-arrow button to add Boolean operators to your search.
  • Click List Topics.Your search will return the first 500 hits. If you want to sort the topic list, click Title, Location, or Rank.
  • Highlight the topic that you want, and then click Display You can also display any topic by double-clicking it.

Refining a Your Search

You can refine a basic search by using wildcard expressions, nested expressions, and Boolean operators. You can also search only on the previous results list, request similar word matches, or search only the titles of topics in the table of contents.

  • To refine a search to include just the last group of topics you searched, select the Search previous results check box.
  • To match similar spellings in a full-text search, select the Match similar words check box.

When Match similar words is selected, the viewer matches minor grammatical variations of the word or phrase you entered, as well as the word or phrase itself. For example, if you entered "test" and selected this box, the Library viewer would find "test", "tests", and "testing". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "installed module" will also match "installing module".

  • To search for words in document titles only, select the Search titles only check box.

Search Syntax

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You can search for any combination of letters (a–z) and numbers (0–9). You cannot search for single letters (a, b, c, etc.) and the following reserved words: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using "double quotes" or (parentheses). You cannot search for quotation marks.

If you are searching for a filename with an extension, you should group the entire string in double quotes ("filename.ext"). Otherwise, the search will treat the period as an OR operator.

Words, Phrases, and Wildcards

You can search for words or phrases and use wildcard expressions. The table below describes the results of these different kinds of searches.

Search for | Example | Results
Single word | Calibrate | Topics that contain the word "calibrate." (You will also find its grammatical variations, such as "calibration" and"calibrated".)
Phrase | "saved configuration" -or- 'saved configuration' | Topics that contain the literal phrase "saved configuration" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying a saved AND configuration, which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | Meas* | Topics that contain the terms "Meas," "measure," "measurement," and so on. The asterisk cannot be the only character in the words.
 | 89?00 | Topics that contain the terms "89500," "89600," "89700," and so on. The question mark cannot be the only character in the term.
 | *936* | Topics that contain the terms "936." "45936,""M9360A," "93600" and so on.
 | *93 | Topics that contain the terms "293," "393," "x93," "ABCD393," "8093," and so on.

Operators: AND, OR, NOT, and NEAR

The AND, OR, NOT, and NEAR operators allow you to refine your search. The following table shows how to use each of these operators.

Search for | Example | Results
Both terms in the same topic | performance AND verification -or- performance & verification | Topics containing both the words "performance" and "verification."
Either term in a topic | front OR panel -or- front | panel | Topics containing either the word "front" or the word "panel."
The first term without the second term | system NOT requirements -or_ system ! requirements | Topics containing the word "system," but not the word "requirements."
Both terms in the same topic, close together | install NEAR hardware | Topics containing the word "install" within eight words of the word "hardware."

Rules for Nested Expressions

The basic rules for searching topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example, "Instrument NOT system OR calibration" finds topics containing the term "instrument" without the term "system", or topics containing the term "instrument" and not "calibration". (On the other hand, "instrument NOT (system OR calibration)" finds topics containing the term "instrument" without either of the terms "system" or "calibration".)
  • Nesting allows you to create more complex search expressions. For example, "instrument AND ((system OR calibration) NEAR performance)" finds topics containing the term "instrument" along with the terms "system" and "performance" close together, or containing "instrument" along with the terms "calibration" and "performance" close together.
  • You cannot nest expressions more than five levels deep.


FAQs

Q. What is Coherent Sampling

A. Coherent Sampling refers to the relationship between the input frequency, sampling frequency, number of cycles in the sampled set and the number of samples. With coherent sampling one is assured that the signal power in an FFT is contained within one FFT bin (assuming a single input tone).

The condition for coherent sampling is given by:

For example if we have Msamples = 211, and fs = 100e6, and we expect and input frequency close to fs/2, let's say fin = 44 MHz,

Then Ncycles = 901.12 which is close to an integer. We could therefore round down to Ncycles = 901 and we would get fin = 43.994140625 Mhz, which is an input frequency that satisfies coherent sampling.

The integer number should be chosen carefully. We have three possible types of integers, even, odd, and prime. Even is not a good idea since we would hit the same code every Msamples, where M can be much less than N. Odd is a better idea since it takes longer to hit the same code. According to some sources a prime number of cycles is the best (with the exception of the prime 2) because it takes a long time before the same code repeats.


Related Documentation

Documentation Access Map

All documentation relating to your Agilent Technologies digitizer may be found either from the CDROM supplied with your product, or from the Agilent website as shown in the diagram below:

Documentation

If you have run the Agilent MD2 software installer for your product on your PC, the related product documentation will have been installed to your hard drive. Otherwise these documents are available for download from the Agilent Technologies website

Document

Startup Guide

Includes procedures to help you to unpack, inspect, install (software and hardware), perform instrument connections, verify operation, and troubleshoot your product. Also includes an annotated block diagram.
User Manual

Provides in-depth information and reference material specific to your digitizer product
Data Sheet

In addition to a detailed product introduction, the data sheet supplies full product specifications.
LabVIEW Driver reference (help system)

Provides detailed documentation of the LabVIEW G driver API functions.
IVI Driver reference (help system)

Provides detailed documentation of the IVI-COM and IVI-C driver API functions, as well as information to help you get started with using the IVI drivers in your application development environment.


Full Product Family Listing & Cross-reference tables

This help file has been organized to allow easy access by arranging the product lines under their form factors listed below:

PCI Express Digitizers

The products in the industry standard PCI Express format benefit from the very high data transfer rates of the PCIe interface, and occupying a single slot in a host PC. They also feature programmable on-board processing capabilities.

Agilent Model Number | Model Name
U1084A | 8-bit High-Speed PCIe Digitizer with on-board signal processing
U5303A | 12-bit PCIe High-speed Digitizer with on-board signal processing
U5309A | 8-bit PCIe High-Speed Digitizers with on-board signal processing

Note: That the U1084A product utilizes PCIe Gen 1.1 and a x4 slot, whereas the U53xx series support PCIe Gen 2.0 and a x8 slot.

PXI Express High-Speed Digitizers

This product line is composed of Agilent PXI Express new generation of high-speed digitizers.

These are PXI Express compliant, using either a PXIe or PXIe Hybrid slot. Designed to benefit from fast data interfaces, the products can be integrated with other test and automation modules in PXIe and Hybrid chassis slots. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems

Agilent Model Number | Model Name
M9202A | PXI Express 12-bit Wideband IF Digitizer
U5203A | PXI Express 12-bit High-Speed Digitizer
PXI Hybrid High-Speed Digitizers

This product line is composed of Agilent PXI Hybrid high-speed digitizers.

These are PXI compliant digitizers, using either a cPCI (J/J2), PXI-1 or PXIe Hybrid slot. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems.

Agilent Model Number | Model Name
M9210A | 10-bit Digitizing Scope
M9211A | 10-bit UWB IF Digitizer
AXIe Digitizers

This product line is composed of Agilent Technologies new generation of AXIe Digitizers.

The AXIe format offers high performance in a highly scalable package, offering at least twice the channel density of currently available comparable solutions. Making it ideally suited to large scale experiments in applied physics, such as particle physics, nuclear fusion, hydrodynamics or microwave radio astronomy.

Agilent Model Number | Model Name
M9703A | AXIe 12-bit Wideband Digitizer
U10xx - PCI / CompactPCI / VME Products

Agilent Technologies Inc. acquired Acqiris SA and its product lines in December 2006. Use the tables below to cross reference the Acqiris model name with the newer Agilent model numbers.

8 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1061A-001-F50 | DC135
U1061A-001-FHZ | DC135HZ
U1061A-002-F50 | DC140
U1061A-002-FHZ | DC140HZ
U1063A-001 | DC265
U1063A-002 | DC270
U1064A-001-F50 | DC211
U1064A-001-FHZ | DC211A
U1064A-002-F50 | DC241
U1064A-002-FHZ | DC241A
U1064A-004-F50 | DC271
U1064A-004-FHZ | DC271A
U1067A-001 | DP105
U1067A-002 | DP110
U1068A-001 | DP210
U1068A-002 | DP211
U1069A-001 | DP214
U1069A-002 | DP235
U1069A-003 | DP240
U1071A-001 | DP1400
U1071A-001-F50 | DP1400
U1071A-001-FHZ | U1071AHZ1
U1071A-002-F50 | U1071A002
U1071A-002-FHZ | U1071AHZ2
U1071A-004-F50 | U1071A004
U1071A-004-FHZ | U1071AHZ4
U1091AC10 | DC110
U1091AD06/07 | DP106
U1091A-003 | DP212
10 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1062A-001 | DC122
U1062A-002-2F5 | DC152
U1062A-002-2FZ | DC152HZ
U1065A-001-FHF | DC222HF
U1065A-001-F50 | DC222
U1065A-002-F50 | DC252
U1065A-002-FHF | DC252HF
U1065A-004-F50 | DC282
U1065A-004-FHZ | DC282HZ
12 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
n/a | DC436
U1066A-002 | DC438
U1066A-001 | DC440
U1070A-003 | DP306
U1070A-002 | DP308
U1070A-001 | DP310
Analyzers and Averagers
Agilent Model Number | Acqiris Model Name
U1080A-001 | AC240
U1080A-002 | SC240
U1081A-001 | AP100
U1081A-002 | AP101
U1081A-003 | AP200
U1081A-004 | AP201
U1082A-001 | AP240
U1082A-002 | AP235
U1091AAC1 | AC210
U1091ASC1 | SC210


Agilent U5303A PCIe Digitizer Introduction

The Agilent Technologies U5303A is a fast 12-bit PCIe digitizer with programmable on-board processing, making it ideal for biotechnology, semiconductors, and physics. The U5303A is particularly suited for OEM Collapsed Original Equipment Manufacturer applications with its fast PCI Express 2.0 eight lanes connection.

The U5303A occupies a single full-length PCIe slot of the host PC. Featuring sample rates of 1.6 GS/s per channel, up to 3.2 GS/s in interleaved mode, along with an analog bandwidth of up to 2 GHz and DDR3 acquisition memory options up to 4 GB, the U5303A includes a Xilinx Virtex-6 FPGA Collapsed Field Programmable Gate Array allowing implementation of custom real-time processing algorithms using the available FPGA development kit.

At the heart of the U5303A is a data processing unit (DPU Collapsed Digital Processing Unit) based on the powerful Xilinx Virtex-6 FPGA. This DPU is responsible for controlling the module functionality, data flow and real-time signal processing. This powerful feature allows data reduction and storage to be carried out at the digitizer level, minimizing transfer volumes and speeding-up analysis.

Figure 1 - U5303A block diaram

Most of the technical specifications concerning your particular digitizer are covered in this manual, however for the complete specifications please refer to the product’s datasheet from the Agilent Technologies web site www.agilent.com/find/digitizers. These data sheets are available in pdf format and are best viewed using Adobe Acrobat software. If you have trouble accessing our web site, or viewing the data sheets, please contact your nearest sales office.


U5303A Front Panel Features

Front Panel Connectors

Connector | Type | Description
TRG IN | MMCX | External trigger input, 50 Ω DC terminated, ±5 V range.
IN 1, 2 SMA

The analog signal inputs, which are DC-coupled and 50 Ω terminated. The input full scale ranges are selectable:

Range | Maximum Input
1 V | 3 Vrms, ±3.6 Vpk
2 V | 4.3 Vrms, ± 6.3 Vpk
JTAG | Micro USB | Provides connection to the DPU for use with the U5340A FDK.
TRG OUT | MMCX | Trigger Out signal. User selectable from several functions.
I/O 1, 2, 3 | MMCX | User configurable Input / Output signal. 3.3 V CMOS and TTL compatible
CLK IN | MMCX | External clock input. AC coupled and 50 Ω terminated, signal level: +5 to +15 dBm. Frequency range: 2 to 3.2 GHz.
REF IN | MMCX | External reference clock input, AC coupled and 50 Ω terminated. It can accept a 100 MHz signal from -3 to +3 dBm.

Front Panel LEDs

Indicator | Purpose | Color | State | Meaning
DPU | DPU status |  | Off | DPU is not configured
 |  |  | Green, blinking | Module initialization in progress
 |  |  | Green | Module OK (firmware not yet loaded)
 |  |  | White | DPU firmware loaded (ready)
STATUS | Module status |  | White, blinking | Firmware initialization in progress
 |  |  | Green, blinking | Module initialization in progress
 |  |  | Yellow, blinking | Warning
 |  |  | Red, blinking | Error
 |  |  | Green | OK (ready)

If warning or error status is observed, please try the following steps:

  • Power-cycle the chassis (If using a PCIe interface to external PC, observe the power sequence requirements)
  • If the error persists please contact Agilent technical support


Channel Input Specifications

This section provides information and specifications regarding the input characteristics of the digitizer.

Channel Input

The U5303A has the following front end capabilities:

Impedance 50 Ω |  | Coupling DC
Full Scale Range | Offset Adjustment | Absolute Maximum | Maximum Signal
1 V, 2 V | ±2 x FS Range | (±5 V) | ±3.6 V (1 V range) ±6.3 V (2 V range)

Impedance & Coupling

The input channel termination is 50 Ω. The input coupling is DC.

Input Protection

The input amplifiers are designed to accept signals below the level shown in the table.

Mezzanine Front-end

The front-end electronics are all mounted on a removable mezzanine card. In the event of accidental damage or as components fatigue over time (e.g. relays in high duty cycle automated testing applications), the mezzanine card allows for fast and efficient replacement.

Bandwidth and Rise Time

The bandwidth specification indicates the frequency at which an input signal will be attenuated by 3 dB (approximately 30% loss of amplitude).

Options |  |  | Input Frequency Range |  | BW Limiter selections
 |  |  | 1 V FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages. | 2 V FSR
-F05 | -SR0 | — | DC to 400 MHz (typical) |  | No BW limiter
 |  | -INT
 | -SR1/-SR2 |  | DC to 650 MHz (typical) |  | 650 MHz
 |  | -INT
-F10 | -SR1/-SR2 | — | DC to 1.9 GHz (typical) | DC to 2.0 GHz (typical) | 650 MHz
 |  | -INT | DC to 1.3 GHz (typical)

The bandwidth also affects the minimum rise and fall times that can be passed through the front-end electronics. A pulse with a very sharp edge will be observed to have a minimum rise time [image] determined by the front-end electronics. In general a pulse with a given 10-90% rise time [image] will be observed with a slower value given by:

Vertical Resolution

The U5303A PCIe High-speed Digitizer uses a 12-bit ADC Collapsed Analog to Digital Converter giving 4096 levels of ~0.25 mV average width when using the 1 V FSR. The effective number of bits (ENOB Collapsed Effective Number Of Bits - expresses the quality of the ADC quantification.) is greater than 9 over the full -F05 bandwidth (M9703A-FRF).

Accuracy and Linearity

This digitizer uses low noise front-end electronics in order to ensure that voltage measurement is made with accuracy and precision. DC accuracy is typically 1%. DC gain accuracy is better than ±0.5 % in the 1 V range, and ±0.7 % in the 2 V range. Offset accuracy is better than ±0.5 % in the 1 V range, and ±1.5 % in the 2 V range.


Data Acquisition

The sections below summarize the data acquisition characteristics:

Sampling Rate

The U5303A Digitizer contains an analog-to-digital conversion (ADC Collapsed Analog to Digital Converter) system that can sample waveforms, in a real time sampling mode, at rates shown in the table below. The maximum sampling rate shown above is achieved by combining the two channels.

Model | Option | Max. Sampling Rate | Available Channels | Resolution | Acquisition Modes
U5303A | -SR0 | 0.5 GS/s | 2 | 12 bits | Single or multi-record (up to 131'072 records)
 | -SR0 and -INT | 1 GS/s | 1
 | -SR1 | 1 GS/s | 2
 | -SR1 and -INT | 2 GS/s | 1
 | -SR2 | 1.6 GS/s | 2
 | -SR2 and -INT | 3.2 GS/s | 1

Acquisition Memory

Data from the ADC is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 1 point to the full amount of acquisition memory available.

Model | Option | Acquisition Memory | Samples/channel
U5303A | -M02 | 256 MB | 64 MS/ch
 | -M10 | 1 GB | 256 MS/ch
 | -M40 | 4 GB | 1 GS/ch

For technical reasons, a certain acquisition memory “overhead” is required for each waveform, reducing the available memory by a small amount. In order to simplify programming, an interface function recommends the best sampling rate and the maximum possible number of data points, taking into account the available memory, the requested time window, the number of records, as well as the required memory overhead.

To ensure maximum sampling rate and high timing resolution, we strongly recommend the use of long acquisition memories whenever possible.

Additional Optional Memory allows the maximum number of records to be increased significantly. However, this memory is divided into 2K sample pages and a record must start at the beginning of the page. Additional memory is used for record time stamps. These constraints must be kept in mind when trying to understand how the driver limits the number of points as the number of records changes. Furthermore, multi-record event readout must read entire pages for each ADC. This can introduce significant overhead for small records and/or when channels are combined.

Single and Multi-Record Acquisition Modes

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) that are made by the ADC at a uniform clock rate.

To maximize sampling rates and utilize memory as efficiently as possible the digitizers include both Single and Sequential storage modes. For both of these modes the data of all of the active channels is acquired synchronously; all of the ADC’s are acquiring data at the same time, to within a small fraction of the maximum sampling rate.

The Single Acquisition mode is the normal operation of most digitizer products. In this mode an acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size and sets the number of records to 1 (default value).

The digitizers also feature a multi-record acquisition mode. This allows the capture and storage of consecutive “single” waveforms. Multi-record acquisition mode is useful as it can optimize the digitizer’s sampling rate and memory requirements for applications where only portions of the signal being analyzed are important. The mode is extremely useful in almost all impulse-response type applications (RADAR, SONAR, LIDAR, Time-of-Flight, Ultrasonics, Medical and Biomedical Research, etc.).

In multi-record acquisition mode the acquisition memory is divided into a pre-selected number of records. Waveforms are stored in successive memory records as they arrive. Each waveform requires its own individual trigger.

Multi-record acquisition enables successive events, which can occur within a very short time, to be captured and stored without loss. A crucial feature of multi-record acquisition mode is that it has a very fast trigger rearm time. A fast trigger rearm helps produce very low “dead time” between the records of a multi-record acquisition. The “dead time” is the period after the end of an event when the card cannot digitize data for a new trigger event.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI resolution determines the resolution of the trigger time stamps. Please refer to the U5303A datasheet for the relevant specifications.

Timebase Range

The timebase range defines the time period over which data is being acquired. For example, the U5303A has a standard acquisition memory of 64 MS/ch and maximum sampling rate of 1.6 GS/s (non-interleaved). Therefore, at the maximum sampling rate, the digitizer can record a signal over a time window of up to 41 ms (approx. 67 M points * 625 ps/point).

Combining channels (Interleaving)

The U5303A digitizer offers the possibility of combining the converters (and their memories) from two channels to analyze a single input channel. With this feature the maximum sampling rate and the maximum amount of acquisition memory can be doubled if all of the input channels are not of immediate interest.

Binary Decimation

A programmable binary decimation may be used to lower the sample rate by a factor of 2n where n is defined in the is in the range of 1 to 10, depending on the model.

e.g. for a U5303A SR2 you can select from 3.2 G/S (with interleaving) down to 3.125 MS/s.

Model Model |  | Decimation Configuration
U5303A | -SR0 | N/A
 | -SR1 | 210
 | -SR2


Trigger

Normally the trigger settings applied to the digitizer are used to determine the time at which the device will stop acquiring data. The various trigger settings are outlined below.

Trigger Source

The trigger source can be a signal applied to either an Input Channel (internal triggering) or the TRG IN front panel input connector (external triggering).

Trigger Impedance & Coupling

The U5303A has a fixed 50 Ω termination impedance with DC coupling.

Trigger Input Bandwidths

The bandwidth of the channel triggers is from DC to 250 MHz. The external trigger inputs have a bandwidth from DC to 2 GHz.

Trigger Level

The trigger level specifies the voltage at which the selected trigger source will produce a valid trigger. All trigger circuits have sensitivity levels that must be exceeded in order for reliable triggering to occur.

Both the external trigger input and channel triggers have a hysteresis of 5% of FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages. (Full Scale Range).

On external trigger, the Full Scale Range FSR is ±5 V, therefore the digitizer will trigger on signals with a peak-to-peak amplitude > 0.5 V.

When using the channel triggers, the trigger level must be set within Offset ± FSR (where FSR is the channel Full Scale Range).

Edge Trigger Slope

The trigger slope defines which one of the two possible transitions will be used to initiate the trigger when it passes through the specified trigger level. Positive slope indicates that the signal is transitioning from a lower voltage to a higher voltage. Negative slope indicates the signal is transitioning from a higher voltage to a lower voltage.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI resolution determines the resolution of the trigger time stamps. Please refer to the U5303A datasheet for the relevant specifications.

Pre- and Post-Trigger Delay

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted within the time interval from 0 to (232 – 1) * block_size (samples), wherewhere block_size is 16 in non-interleaved mode and 32 in interleaved (combined) mode.

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

  • The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.
  • The condition of 0% pre-trigger (which is identical to a post-trigger of 0) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.
  • The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers treat pre- and post-trigger delays as a single parameter in seconds that can vary between

–nbrSamples * samplingInterval (100% pre-trigger) and +maxPostTrigSamples * samplingInterval (max post-trigger).


External Clock and Reference

For applications where the user wants to replace the internal clock of the digitizer and drive the ADC Collapsed Analog to Digital Converter with an external source, either an External Clock or an External Reference signal can be used. The Clock or Reference signals can be entered into the digitizer by the dedicated REF IN and CLK IN connectors.

External Clock (CLK IN)

The External Clock may be used, it must be continuously present if selected for the digitizer to operate correctly. The input is 50 Ω, AC coupled.

Model | Frequency Range | Amplitude | Treshold
-SR0 | 500 MHz to 1 GHz | +5 to +15 dBm | 0 V
-SR1 | 1 GHz to 2 GHz
-SR2 | 2 GHz to 3.2 GHz

External Reference (REF IN)

For applications that require greater timing precision and long-term stability than is obtainable from the internal clock, a 100 MHz Reference signal can be used. The input is 50 Ω terminated and AC coupled.

If your input is not at exactly the specified value, you must remember to compensate for the difference in your application since the digitizer and the driver have no way to know about such deviations.

Parameter | Value | Tolerance
Nominal Frequency | 100 MHz | ±100 kHz
Amplitude | -3 to +3 dBm |

If synchronization between several digitizers is required, the reference signal should be applied to all of them.


Internal Calibration

The digitizer includes a high precision voltage source and a 16-bit DAC, used to perform the input voltage and offset calibration.

The software drivers supplied include calibration functions for the timing, gain and offset parameters, which can be executed upon user request. The digitizers are never calibrated in an “automatic” way, (i.e. as a side effect of another operation). This ensures programmers have full control of all calibration operations performed through software in order to maintain proper event synchronization within automated test applications.

For accurate time and voltage measurements it is recommended to perform a calibration once the module has attained a stable operating temperature (usually reached with a few minutes of digitizer operation after power on). And subsequently a self-calibration should be carried out after any configuration changes are made to the digitizer, before making acquisitions.

A full internal calibration of a digitizer can be time consuming because of the many possible configuration states. Therefore, the self-calibration is performed only for the current configuration state, and is mandatory before making any acquisition. Indeed the MD2 driver will prevent an acquisition from being performed unless a self-calibration has first been completed. A new self-calibration will be required after every change of configuration of the instrument.

Calibration can usually be performed with signals present at the channel, external, and clock inputs. However, to ensure the best performance, or if the calibration is found to be unreliable, as shown by a calibration failure status, it will be necessary to remove such signals.

An application program will close devices if it exits normally. When a digitizer is closed in this way its power consumption will be reduced. This has the consequence that if another application program is started later an appropriate warm-up period may have to be respected before a calibration is called for and full performance expected.

Factory Calibration

Whilst the Internal Calibration function will provide a good degree of confidence that your instrument is operating within its specifications on a day-to-day basis, Agilent recommends that each instrument undergoes a Factory Calibration at least annually to ensure that it remains within the specified performances.

Factory Calibration is the process of measuring the actual performance of an instrument-under-test using lab instruments that in turn have significantly better performance than the instrument-under-test. Lab instrument performance must be traceable to the International System (SI) Units via a national metrology institute (NIST, NPL, NRC, PTB, CENAM, INMETRO, BIPM, etc.)

The measured performance is then compared to published data sheet specifications. Agilent Technologies tests the performance corresponding to all data sheet specifications, for all installed options, every time. If we observe your instrument to be out-of-specification, we always adjust it and re-test before we return it to you.

For more information, or to return your instrument to Agilent for calibration please see www.agilent.com/find/calibration


External Trigger Output

You are here: U5303A User Manual > Trigger Output

Trigger Output

When the digitizer is ready to be triggered and a valid trigger signal occurs, a trigger output pulse is generated for external use. This signal is available on the front panel TRG OUT MMCX connector, and may be enabled or disabled as required.

Figure 2 - Trigger Output Block diagram:

In the default software configuration, the output swing is 1.6 V (±0.8 V) when unloaded and 0.8 V (±0.4 V) when terminated on 50 Ω. The rise and fall times are 2.5 ns typical. The offset can be adjusted, by software control in the range [–2.5 V to +2.5 V] unloaded, or [-1.25 V to +1.25 V] into 50 Ω. The maximum output current capability is ±15 mA. As the output is retro-terminated, it is possible to drive a 50 Ω line un-terminated (HiZ) without loss of performance.

For a TTL compatible signal, set the offset to 1.0 V and the swing at destination will be +0.2 to +1.8 V.

For an ECL compatible signal, terminated on 50 Ω to –1.2 V, set the offset to –1.2 V and the output will be in the range [–0.8 to –1.6 V]).

Alternatively, to reduce the current drawn from the digitizer, the terminations shown here can be used:

Figure 3 - Suggested trigger signal terminations

The External Trigger Output functionality is implemented in the hardware. No Trigger Out signal occurs for software-generated triggers.


Special Inputs & Controls

You are here: U5303A User Manual > Multi-Purpose Inputs and Outputs

Multi-Purpose Inputs and Outputs

The IO connectors may be used for any of the functions shown in the following table:

IO Connector Functions | Type | Description of signal | Notes
Inputs
Disabled | - | IO connector is disabled. |
In-ToLogicDevices | - | The Pio_In input signal to the DPU user core (see U5340A FDK manual user core signal description) IO 1: Pio_In(0), IO 2: Pio_In(1) These signals are resynchronized to the sampling clock divided by 16 and transferred from the Control FPGA to the DPU with a non-deterministic clock cycle latency. | Used only with the U5340A FPGA Development Kit.
In-AccumulationEnable | Level |  | IO 1 only. Requires -AVG or -PKD option.
Outputs |  |  |
Out-LogicDeviceDPUA | - | The Pio_Out output signal from the DPU user core (see FDK user manual, user core signal description) IO 1: Pio_Out(0) IO 2: Pio_Out(1) These signals are transferred from the DPU to the Control FPGA with a non-deterministic clock cycle latency. | Used only with the U5340A FPGA Development Kit.
Out-FPGASyncOut | Pulse | The SyncOut output signal from the DPU user core (see FDK manual user core signal description) This signal is transferred from the DPU to the Control FPGA with a deterministic clock cycle latency. | Used only with the U5340A FPGA Development Kit.
Out-100MHzReferenceClockDivBy2 | Clock | The 100 MHz reference clock divided by 2 (50 MHz) | IO 1 only
Out-SamplingClockDivBy32 | Clock | The sampling clock divided by 32 | IO 1 only
Out-AcquisitionActive | Level | Indicates that the acquisition is currently running. | IO 1 & 2 only
Out-TriggerArmed | Pulse | Trigger is armed. | IO 1 & 2 only
Out-Low Level | Level | Fixed 'low' level signal for debug purposes. | IO 1 & 2 only
Out-High Level | Level | Fixed 'high' level signal for debug purposes. | IO 1 & 2 only
Out-TriggerAcceptedResync | Pulse | Active when a valid trigger event has occurred. This signal is resynchronized to the sample clock. | IO 1 & 2 only
Out-AccumulationActive | Level | Indicates that the accumulation is currently running. | IO 2 only. Requires -AVG or -PKD option.
Out-AveragerAwg | - | Self-Trigger output. | IO 3 only. Requires -AVG or -PKD option.

Signal Logic Levels

The multi-purpose IO signals are 3.3 V CMOS compatible. The levels shown in the table below should be observed.

Direction | Low level | High level
Input | <0.8 V | >2.0 to 3.45 V
Output | In the range 0 to 0.8 V | In the range 1.6 to 3.3 V
As an Input

The input is high-impedance and will be pulled high if unconnected via an internal weak pull-up.

As an Output

The high level output will typically give 0.8 V into 50 Ω. As can be seen in the diagram below, the 3.3 V output buffer has a 50 Ω resistor in series. Therefore the available output high level voltage will depend on the load applied. In the example below a 50 Ω termination will result in a nominal high level of 1.6 V. (Vo = Rload/50 + Rload * 3.3)

Figure 4 - Output equivalent circuit


Signal Processing Options

This section describes options which may be used when processing the signal.

The following table show the availability of firmware options versus sampling rate.

Firmware | Sampling Rate
 | -SR0 | -SR1 | -SR2
-AVG | — | ü | ü
-PKD | — | ü | ü
-TSR | — | ü | ü

Averager (AVG)

Peak Detection (PKD)

Triggered Simultaneous Acquisition and Readout (TSR)


Averager (AVG)

Introduction

Averaging signals reduces random noise effects, improving the signal-to-noise ratio, as well as increasing resolution and dynamic range. The fast sampling rate is achieved with a single trigger and acquisition, and does not require the use of equivalent-time sampling techniques.

The main features are:

  • Synchronous, single-channel and dual-channel, real-time sampling and averaging up to 3.2GS/s.
  • Averaging from 1 to 520,000 triggers per record in steps of 8 triggers (except the first 8 triggers). Some possible values are 1,2,3,4,5,6,7,8,16,24,32,… triggers.
  • Effective acquisition length from 1K up to 480KSamples in single channel or up to 240KSamples per channel in dual-channel.
  • Noise Suppressed Accumulation (NSA).
  • Self-Trigger mode for minimal synchronous (pattern) noise.
  • Baseline stabilization algorithm and digital offset.

Noise Suppressed Accumulation (NSA)

In some applications, such as time-of-flight spectroscopy, the signal is a rare event sitting on top of a noisy baseline and the averaging process reduces the random noise.

As a consequence, to enhance the digitizers ability to detect such signals in the presence of synchronous noise, the averaging firmware allows the user to set a Threshold that must be exceeded for each data value to be entered into the sum. Furthermore, the NoiseBase can be subtracted from each data value above threshold before the accumulation is done (See Figure 1). The NoiseBase should always be equal or smaller than the Threshold.

Figure 1. Signal detection using noise suppressed accumulation

Parameters (Channels2.Item2.Accumulation.NSA interface):

Enabled: Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager.

NoiseBase: Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. This parameter is defined per channel in ADC Collapsed Analog to Digital Converter counts.

Threshold: Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. This parameter is defined per channel in ADC counts.

Trigger Modes

Apart from the trigger sources described in the section Trigger (internal and external triggering), this option provides another trigger mode to warranty minimum synchronous (pattern) noise. This trigger source is called Self-Trigger.

In applications where multiple waveforms are accumulated, the synchronicity between ADCs sequence and trigger results in a synchronous noise which often becomes the dominant factor. In theory, setting the external trigger at a specific trigger frequency which ensures that each waveform to be accumulatedted starts with a different ADC, the user can reduce the synchronous noise. However, in a real application is not possible en assure the trigger stability at the optimum condition due to multiple factors, for instance temperature variations.

Therefore, the only way to warranty the minimum synchronous noise is using the Self-Trigger mode. In this mode, the trigger is generated internally in the digitizer and propagated outside the digitizer through the front panel IO 3. The trigger is controlled to ensure that each waveform to be accumulated starts at a different ADC in the ADC sequence. To use the Self-Trigger mode, the Trigger ActiveSource must be set to "SelfTrigger".

Figure 2 shows the signal to noise ratio using an external trigger at a frequency multiple of the sampling frequency (worst case) and the Self-Trigger at any frequency (best case).

Figure 2. Signal to noise ratio vs Number of averagers

Parameters

ActiveSource (Trigger2.ActiveSource interface): Specifies the trigger source. There are three trigger sources: internal, external and self-trigger. If the Self-Trigger mode is selected the Self-Trigger parameters should be set and the IO 3 output should be enabled

Frequency (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies the frequency of the Self-Trigger square wave signal. The units are Hertz.

DutyCycle (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Configures the duty cycle of the Self-Trigger square wave signal. Units are percentage of the period.

Slope (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.

Out-AveragerAwg (ControlIOs interface): Self-Trigger signal is propagated through the IO 3.

Baseline Stabilization and Digital Offset

For applications where extraordinary baseline stability is required, this option provides a stabilization algorithm with a resolution of 0.0625 LSB Collapsed Least Significant Bit:- The bit that represents the smallest fraction of a value.. In combination with the baseline stabilization, a digital offset with a resolution of 0.5 LSB can be applied.

This algorithm is specially implemented for applications where most of the data acquired is nearby a baseline and the data of interest are fast peaks above/below this baseline. Two programmable thresholds should be configured to define the baseline margins and avoid non desired signal data in the computation.

There are two mode of operation:

a) Continuous: the baseline stabilization is active all the time (see Figure 3).

b) Between acquisitions: the baseline stabilization is active only outside the acquisition window.

Figure 3. Continuous baseline stabilization example

Parameters (Channels2.Item2.Accumulation.BaselineCorrection interface):

ThresholdHigh/ThresholdLow: defines the baseline range. This parameter is defined per channel in ADC counts.

DigitalOffset: offset added after the baseline stabilization. This parameter is defined per channel ADC counts.

Mode: disabled, continuous or between acquisitions.

Multi-Purpose Inputs and Outputs (IO 1, 2)

The multi-purpose inputs and outputs (IO 1, 2) in the front panel may be used to control the accumulation or read the digitizer status:

Parameters (ControlIOs interface)

In-Accumulation enable: digitizer input (IO 1). This signal controls the averaging sequence checking its value only at the averager start. If the accumulation enable is '1' at the start, the averager will perform the averager independiently of this input value. By the contrary, if the accumulation enable is '0' at the start, the digitizer will wait until the accumulation enable rises starting the averaging at that moment (no need for a new start).

Out-Accumulation active: digitizer output (IO 2). This signal informs that the digitizer is busy acquiring or accumulating the last averages.

Out-Acquisition active: digitizer output (IO 1 or IO 2). This signal informs that the digitizer is busy acquiring.

Other AVG Parameters

Finally, there are two specific parameters commonly used in the averager:

NumberOfAverages: number of waveforms to average in the record.

DataInversionEnabled: the data acquired may be inverted if desired.

AVG Configuration

The interfaces/methods/properties (functions/attributes) listed below are provided by the Agilent MD2 driver. Detailed help on these interfaces may be found in the AgMD2 IVI Driver Reference Manual.

IVI-COM

Interface | Method / Property name
IAgMD2TriggerSource2SelfTrigger | AbortGeneration
IAgMD2TriggerSource2SelfTrigger | InitiateGeneration
IAgMD2TriggerSource2SelfTrigger | Mode <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Configure
IAgMD2TriggerSource2SelfTriggerSquareWave | DutyCycle <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Frequency <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Slope <p>
IAgMD2TriggerSource2SelfTriggerCustomWave | LoadConfigurationFile
IAgMD2Acquisition2 | Mode <p>
IAgMD2Acquisition2 | NumberOfAverages <p>
IAgMD2Channel2 | DataInversionEnabled <p>
IAgMD2Channel2AccumulationNSA | Configure
IAgMD2Channel2AccumulationNSA | Enabled <p>
IAgMD2Channel2AccumulationNSA | NoiseBase <p>
IAgMD2Channel2AccumulationNSA | Threshold <p>
IAgMD2Channel2AccumulationBaselineCorrection | Configure
IAgMD2Channel2AccumulationBaselineCorrection | DigitalOffset <p>
IAgMD2Channel2AccumulationBaselineCorrection | Mode <p>
IAgMD2Channel2AccumulationBaselineCorrection | ThresholdHigh <p>
IAgMD2Channel2AccumulationBaselineCorrection | ThresholdLow <p>

IVI-C

Functions

AgMD2_SelfTriggerAbortGeneration

AgMD2_SelfTriggerInitiateGeneration

AgMD2_SelfTriggerSquareWaveConfigure

AgMD2_SelfTriggerCustomWaveLoadConfigurationFile

AgMD2_NSAConfigure

AgMD2_BaselineCorrectionConfigure

Attributes

AGMD2_ATTR_SELF_TRIGGER_MODE

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_FREQUENCY

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_SLOPE

AGMD2_ATTR_ACQUISITION_MODE

AGMD2_ATTR_ACQUISITION_NUMBER_OF_AVERAGES

AGMD2_ATTR_CHANNEL_DATA_INVERSION_ENABLED

AGMD2_ATTR_NSA_ENABLED

AGMD2_ATTR_NSA_NOISE_BASE

AGMD2_ATTR_NSA_THRESHOLD

AGMD2_ATTR_BASELINE_CORRECTION_MODE

AGMD2_ATTR_BASELINE_CORRECTION_THRESHOLD_HIGH

AGMD2_ATTR_BASELINE_CORRECTION_THRESHOLD_LOW

AGMD2_ATTR_BASELINE_CORRECTION_DIGITAL_OFFSET


Peak Detection (PKD)

Introduction

The Peak Detection firmware allows real-time acquisition and peak detection for the models supported. Moreover, there is the possibility to generate a histogram of peak versus time for successive acquisitions.

Note that PKD does not reduce the amount of data memorized. This function searches for the peaks, sets the rest of the data to zero (where there is no peak) and memorizes the data set to zero and the peaks.

The main features are:

  • Synchronous, single-channel and dual-channel, real-time sampling and peak detection up to 3.2GS/s.
  • Effective acquisition length from 1K up to 480KSamples in single channel or up to 240KSamples per channel in dual-channel.
  • Self-Trigger mode for minimal synchronous noise.
  • Baseline stabilization algorithm and digital offset.

Peak Detection Algorithm

Nine samples are used to validate if a sample corresponds to a peak; the sample itself, along with the four samples before and after that sample are considered.

The sample will be considered as a peak, if within the 9 samples analyzed: a rising edge is found before the sample that exceeds the programmable delta ΔRise, a falling edge is found after the sample that exceeds the programmable delta ΔFall, and the sample is the maximum of all points between the two defined rising and falling edges. There is additional verification to make sure that only one peak is found within the rising and falling edge region.

Using this algorithm, peaks can be found on-the-fly in signals with frequencies up to half the sample rate.

Figure 1. Peak detection algorithm

Parameters(Channels2.Item2.PeakDetection interface):

RisingDelta: defines the amount by which two consecutive samples must differ to be considered as rising edge in the peak detection algorithm.

FallingDelta: defines the amount by which two consecutive samples must differ to be considered as falling edge in the peak detection algorithm.

AmplitudeAccumulationEnabled: selects if the peak value is stored or the peak value is forced to ‘1’.

Trigger Modes

Apart from the trigger sources described in the section Trigger (internal and external triggering), this option provides another trigger mode to warranty minimum synchronous (pattern) noise. This trigger source is called Self-Trigger.

In applications where multiple waveforms are accumulated, the synchronicity between ADCs sequence and trigger results in a synchronous noise which often becomes the dominant factor. In theory, setting the external trigger at a specific trigger frequency which ensures that each waveform to be accumulatedted starts with a different ADC Collapsed Analog to Digital Converter, the user can reduce the synchronous noise. However, in a real application is not possible en assure the trigger stability at the optimum condition due to multiple factors, for instance temperature variations.

Therefore, the only way to warranty the minimum synchronous noise is using the Self-Trigger mode. In this mode, the trigger is generated internally in the digitizer and propagated outside the digitizer through the front panel IO 3. The trigger is controlled to ensure that each waveform to be accumulated starts at a different ADC in the ADC sequence. To use the Self-Trigger mode, the Trigger ActiveSource must be set to "SelfTrigger".

Figure 2 shows the signal to noise ratio using an external trigger at a frequency multiple of the sampling frequency (worst case) and the Self-Trigger at any frequency (best case).

Figure 2. Signal to noise ratio vs Number of averagers

Parameters

ActiveSource (Trigger2.ActiveSource interface): Specifies the trigger source. There are three trigger sources: internal, external and self-trigger. If the Self-Trigger mode is selected the Self-Trigger parameters should be set and the IO 3 output should be enabled

Frequency (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies the frequency of the Self-Trigger square wave signal. The units are Hertz.

DutyCycle (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Configures the duty cycle of the Self-Trigger square wave signal. Units are percentage of the period.

Slope (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.

Out-AveragerAwg (ControlIOs interface): Self-Trigger signal is propagated through the IO 3.

Baseline Stabilization and Digital Offset

For applications where extraordinary baseline stability is required, this option provides a stabilization algorithm with a resolution of 0.0625 LSB Collapsed Least Significant Bit:- The bit that represents the smallest fraction of a value.. In combination with the baseline stabilization, a digital offset with a resolution of 0.5 LSB can be applied.

This algorithm is specially implemented for applications where most of the data acquired is nearby a baseline and the data of interest are fast peaks above/below this baseline. Two programmable thresholds should be configured to define the baseline margins and avoid non desired signal data in the computation.

There are two mode of operation:

a) Continuous: the baseline stabilization is active all the time (see Figure 3).

b) Between acquisitions: the baseline stabilization is active only outside the acquisition window.

Figure 3. Continuous baseline stabilization example

Parameters (Channels2.Item2.Accumulation.BaselineCorrection interface):

ThresholdHigh/ThresholdLow: defines the baseline range. This parameter is defined per channel in ADC counts.

DigitalOffset: offset added after the baseline stabilization. This parameter is defined per channel ADC counts.

Mode: disabled, continuous or between acquisitions.

Multi-Purpose Inputs and Outputs (IO 1, 2)

The multi-purpose inputs and outputs (IO 1, 2) in the front panel may be used to control the accumulation or read the digitizer status:

Parameters (ControlIOs interface)

In-Accumulation enable: digitizer input (IO 1). This signal controls the averaging sequence checking its value only at the averager start. If the accumulation enable is '1' at the start, the averager will perform the averager independiently of this input value. By the contrary, if the accumulation enable is '0' at the start, the digitizer will wait until the accumulation enable rises starting the averaging at that moment (no need for a new start).

Out-Accumulation active: digitizer output (IO 2). This signal informs that the digitizer is busy acquiring or accumulating the last averages.

Out-Acquisition active: digitizer output (IO 1 or IO 2). This signal informs that the digitizer is busy acquiring.

Other PKD Parameters

NumberOfAverages: number of waveforms to average in the record.

Data inversion: the data acquired may be inverted if desired.

PKD Configuration

The interfaces/methods/properties (functions/attributes) listed below are provided by the Agilent MD2 driver. Detailed help may be found in the AgMD2 IVI Driver Reference Manual.

IVI-COM

Interface | Method / Property name
IAgMD2TriggerSource2SelfTrigger | AbortGeneration
IAgMD2TriggerSource2SelfTrigger | InitiateGeneration
IAgMD2TriggerSource2SelfTrigger | Mode <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Configure
IAgMD2TriggerSource2SelfTriggerSquareWave | DutyCycle <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Frequency <p>
IAgMD2TriggerSource2SelfTriggerSquareWave | Slope <p>
IAgMD2TriggerSource2SelfTriggerCustomWave | LoadConfigurationFile
IAgMD2Acquisition2 | Mode <p>
IAgMD2Acquisition2 | NumberOfAverages <p>
IAgMD2Channel2 | DataInversionEnabled <p>
IAgMD2Channel2AccumulationBaselineCorrection | Configure
IAgMD2Channel2AccumulationBaselineCorrection | DigitalOffset <p>
IAgMD2Channel2AccumulationBaselineCorrection | Mode <p>
IAgMD2Channel2AccumulationBaselineCorrection | ThresholdHigh <p>
IAgMD2Channel2AccumulationBaselineCorrection | ThresholdLow <p>
IAgMD2Channel2PeakDetection | Configure
IAgMD2Channel2PeakDetection | AmplitudeAccumulationEnabled <p>
IAgMD2Channel2PeakDetection | FallingDelta <p>
IAgMD2Channel2PeakDetection | RisingDelta <p>

IVI-C

Functions

AgMD2_SelfTriggerAbortGeneration

AgMD2_SelfTriggerInitiateGeneration

AgMD2_SelfTriggerSquareWaveConfigure

AgMD2_SelfTriggerCustomWaveLoadConfigurationFile

AgMD2_BaselineCorrectionConfigure

AgMD2_PeakDetectionConfigure

Attributes

AGMD2_ATTR_SELF_TRIGGER_MODE

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_FREQUENCY

AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_SLOPE

AGMD2_ATTR_ACQUISITION_MODE

AGMD2_ATTR_ACQUISITION_NUMBER_OF_AVERAGES

AGMD2_ATTR_CHANNEL_DATA_INVERSION_ENABLED

AGMD2_ATTR_BASELINE_CORRECTION_MODE

AGMD2_ATTR_BASELINE_CORRECTION_THRESHOLD_HIGH

AGMD2_ATTR_BASELINE_CORRECTION_THRESHOLD_LOW

AGMD2_ATTR_BASELINE_CORRECTION_DIGITAL_OFFSET

AGMD2_ATTR_PEAK_DETECTION_RISING_DELTA

AGMD2_ATTR_PEAK_DETECTION_FALLING_DELTA

AGMD2_ATTR_PEAK_DETECTION_AMPLITUDE_ACCUMULATION_ENABLED


Triggered Simultaneous Acquisition and Readout (TSR)

For instruments with both the DTG and the TSR options enabled, acquisition and readout can be performed simultaneously. TSR is only available in standard digitizer mode.

If the TSR Enabled property is set to true (and the Initiate Acquisition function is launched), the instrument will acquire data to a circular buffer that can be read simultaneously. The user has to poll on the TSR IsAcquisitionComplete property to check for the availability of data. Once enough data is available, it can be fetched through standard (single- or multi-record) fetch functions. The TSR Continue function can be called to release the buffer containing the read data and make it available for the next acquisitions. The TSR MemoryOverflowOccurred property indicates that no more memory is available to perform additional acquisitions, implying that follow-on triggers will be lost.

A typical usage example is shown below (pseudo-instructions):

Enable TSR operation

Initiate acquisition

Loop until needed

Check for memory overflow

Poll for acquisition completion

Fetch data

Continue (release memory)

End loop

Abort acquisition

A complete C++ example for TSR features can be found in the directory:

<IVIROOTDIR>\Drivers\AgMD2\Examples\Visual Studio\Cpp\Cpp_TSR

Due to design constraints, the number of trigger events needed to have an acquisition complete can be higher than the number of records configured (through NumRecordsToAcquire property). It is therefore mandatory to query the TSR IsAcquisitionComplete property to check for data availability.

TSR Configuration

The interfaces/methods/properties (functions/attributes) listed below are provided by the Agilent MD2 driver. Detailed help may be found in the AgMD2 IVI Driver Reference Manual.

IVI-COM

Interface | Method / Property name
IAgMD2Acquisition2TSR | Continue
IAgMD2Acquisition2TSR | Enabled <p>
IAgMD2Acquisition2TSR | IsAcquisitionComplete <p>
IAgMD2Acquisition2TSR | MemoryOverflowOccurred <p>

IVI-C

Functions

AgMD2_TSRContinue

Attributes

AGMD2_ATTR_TSR_ENABLED

AGMD2_ATTR_TSR_IS_ACQUISITION_COMPLETE

AGMD2_ATTR_TSR_MEMORY_OVERFLOW_OCCURRED


Electrical & Environmental Specifications

For full specifications, please refer to the product data sheet which may be found on the CD which came with your product, or from the Agilent Technologies website: www.agilent.com/find/U5303A


Programming Information

This section provides general programming advice and specific information regarding the use of the Agilent drivers.

The AgMD2 API documentation can be found in Start > All programs > Agilent IVI Drivers > AgMD2 Digitizer > AgMD2 Documentation

Program examples can be found in Start > All programs > Agilent IVI Drivers > AgMD2 Digitizer >Examples

ApplySetup

Known issues for MATLAB users

Very Long Data Transfers


ApplySetup

The MD2 driver implements the following consistent behavior: No configuration change is applied immediately to the instrument hardware. Specifically, this means that setting any property/attribute only changes the 'setup' in the driver, and an explicit call to ApplySetup is required to implement the change in the instrument hardware.

There are some exceptions for 'actions': being methods/functions that perform an action which e.g. modifies also the instrument's state.

The following methods WILL perform an implicit ApplySetup before the actual action:

Actions with implicit ApplySetup

Method name | Description
SelfTest | To insure the instrument is actually in the desired state before doing the self test.
SelfCalibrate | To insure the instrument is actually in the desired state before self-calibrating.
Initiate | To apply the configured setup to the instrument hardware before starting the measurement.
Read | All Read methods start by performing an Initiate followed by Wait and then Fetch.
Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.


Known issues for MATLAB users

The following table details the supported platforms and known issues for MATLAB drivers:

MATLAB Version | Windows 32-bit |  | Windows 64-bit
 | IVI-C | IVI-COM | IVI-C | IVI-COM
MATLAB R2012b 32-bit | Ok See notes: 2, 3, 4. | Ok See note 1. | Ok See notes: 2, 3, 4. | Ok See note 1.
MATLAB R2012b 64-bit | Not applicable | Not applicable | Ok See notes 2, 3. | Not supported
MATLAB R2013a (or newer) 32-bit | Ok See notes: 3, 4. | Ok See note 1. | Ok See notes: 3, 4. | Ok See note 1.
MATLAB R2013a (or newer) 64-bit | Not applicable | Not applicable | Ok See notes: 2, 3. | Not supported

  1. IVI-COM: Inherent FetchMultiRecordWaveform functions do not work. Please use the specific equivalent functions instead.
  2. IVI-C: Functions name has to be given in lower case through the invoke function. MATLAB R2013a contains a fix for this issue.
  3. IVI-C: The command 'mex -setup' has to be run each time when switching from a version of MATLAB to another to avoid a crash.
  4. IVI-C: When running the 'mex -setup' command, another supported compiler has to be selected than the one provided by MathWorks (Lcc). Otherwise Int64 attributes will not be supported.


Very Long Data Transfers

The low-level data transfers are handled by VISA which has internal completion timeouts. When using the maximum available memory with the larger memory options, reading out the whole waveform in a single Fetch call can be very long, and may result in such VISA timeouts. In this case, the driver reports a "VISA error: ReadBurst32 failed". To avoid this error it is recommended to split transfers larger than 512 MBytes into multiple calls to the appropriate Fetch function.


Utilities

This section describes supplied programs which may be used to configure various aspects of your instruments:

Firmware Upgrade Utility


SFP Command Line Switches

You are here: U5303A User Manual > Utilities > Firmware Upgrade Utility

Firmware Upgrade Utility (AgMD2UpdateFirmware)

The AgMD2UpdateFirmware programming utility (AgMD2UpdateFirmware.exe) is used to load firmware to your Agilent instrument.

AgMD2UpdateFirmware General Information

Syntax:
AgMD2UpdateFirmware.exe [VISA resource string] [ConfigFlashCtrlFpga] [<filename>]

All of the listed switches are mandatory, please see the notes below for details.

Filename conventions

Files with the ".mcs" extension contain instrument operating firmware generated by Agilent, but may be used on any instrument of the appropriate model type.

If one or mores spaces appear in the filename or path, the double quotes are required on the filename string as shown in the examples below.

It is not possible for the utility to check that the file is suitable for the FPGA Collapsed Field Programmable Gate Array / CPLD of the specified device, so please use this mode carefully. Programming a device with the incorrect firmware file may render it unusable.
However, as long as the device has not yet been re-booted (power cycled) it will be possible to re-write the correct file. Conversely, if the device has been incorrectly programmed and subsequently re-booted, it will be necessary to return it to an Agilent Service Center for recovery.

Instructions:

Open a Command Prompt Window (Start > Programs > Accessories > Command Prompt) and run the following commands:.

cd C:\Program Files (x86)\Agilent\MD2\Bin
AgMD2UpdateFirmware.exe PXIx::0::0::INSTR ConfigFlashCtrlFpga "C:\Program Files (x86)\IVI Foundation\IVI\Drivers\AgMD2\Firmware\U530nACTRL_DPULX2.mcs"

U530n is the model type (for example U5303ACTRL_DPULX2.mcs or U5309ACTRL_DPULX2.mcs)

PXIx::0::0::INSTR is the VISA resource string, it must match the resource string as shown in the Agilent Connection Expert. You can find the VISA resource string in the Agilent Connection Expert by clicking on the U530nA and then on the Instrument Properties tab (see U530nA Startup Guide > "Step 5: Verify Operation of the U530nA Module" for more information).

"Firmware update successful" is displayed on the screen, once the programming is completed,

Shutdown and restart your computer to take into account the modifications.


Accessories

U1092A-HVS SMA Input Over-voltage Protection


U1092A-HVS SMA Input Over-voltage Protection

This overvoltage protection kit allows the digitizers with 50 Ohm input (not high-impedance input models) to withstand a high voltage surge of up to 5 kV.

The overvoltage protection kit contains 2 parts:

  • A 3dB SMA Attenuator
    • Length: 22 mm
    • Diameter: 7.1 mm
    • Weight: 4 g
  • A 90 V SMA Spark Gap
    • Length: 39.5 mm
    • Diameter: 15.3 mm
    • Weight: 20 g
Specifications
Parameter | Value
Frequency range | DC to 1 GHz
Input impedance | 50 Ω
Attenuation | 3 dB
VSWR (DC to 1 GHz) | < 1.25
Impulse discharge current (8/20 us pulse) | 10 kA

Install the Attenuator and Spark Gap as shown in the diagram below:

Figure 5 - PXIe module with Input Over-voltage protection fitted

Both the Spark Gap and the Attenuator MUST be used together in order to fully protect the modules.

In order to limit the input current, the Attenuator MUST be inserted between the Spark Gap and the input of the module.